Part I: Fundamental
HSRP(Hot Standby Router Protocol):Cisco独享的第三层协议书。
HSRP为IP网络出示网络冗余,保证 客户总流量能马上并全透明地修复网络界限机器设备或连接电源电路中的第一跳常见故障。
在LAN中,好几个router构成一个HSRP组,在其中一个router代表这一HSRP分享这一LAN中的数据流,其他全部router只推送HSRP hello来保持这类HSRP组关联。
一个HSRP组共享一个IP和一个MAC地址。每一个router能够添加好几个组。
一个HSRP组由一台active router,一台standby router及other routers。
1>active router分享偏向VIP的数据流,并推送HSRP hello包给全部其他HSRP组员。(最后处在active state)
2>standby router不分享偏向VIP的数据流,推送HSRP hello包给全部其他HSRP组员,并监管active router的情况。(最后处在standby state)
3>other routers不分享偏向VIP的数据流,只监管HSRP hello包,不推送。他们实行一般router的工作中,只分享总体目标为他们自己的排序,不分享总体目标为VIP的详细地址。(最后处在listen state)

Part II: HSRP Operation
当standby router在一定時间内沒有接到active router的hello包时,它就觉得active router出現常见故障了,并替代它的active router的人物角色。由于host机器设备应用VIP及VMAC来标志他们的网关设备,全部他们不容易发觉这类变动,也不会觉得到服务项目的终断。

active router的挑选:
1>首选priority大的HSRP router,默认设置的priority数值100
2>首选lowest mac详细地址

为了更好地便捷开展三层交换机,一个router能够归属于好几个HSRP组的组员,每一个HSRP组有一个VIP及VMAC。
一个LAN数最多适用255个HSRP组。

假如host机器设备传送数据排序给VIP的VMAC详细地址,由active router来开展相对的数据流分享。
假如host机器设备推送一个对VIP的ARP要求,由active router用相对的VMAC来回复。


Part III: VMAC Format
VMAC详细地址由3一部分构成:
1>Vendor ID:MAC地址的前3个字节数
2>HSRP code:两个字节数,一般为07.ac,标示此详细地址为HSRP router。
3>Group ID:MAC地址的最终一个字节,为HSRP的组号。
HSRP(热备份路由器协议)的详细介绍 HSRP 安全其它  第1张 HSRP(热备份路由器协议)的详细介绍 HSRP 安全其它  第2张   Part Ⅶ:HSRP Command Reference
1> standby {group-number} ip {virtual-ip-address}
group-number:默认设置为0,可配备范畴0-255
注:应用HSRP时,host机器设备不可以发觉HSRP router的真正MAC地址,因此 在配备了HSRP时,cisco机器设备全自动禁止使用了ICMP跳转:no ip redirects

2> standby {group-number} priority {priority-value}
priority:默认设置为100,可配备范畴0-255
priority最大的router变成active router,priority同样,则最大ip详细地址的router为active router

3> standby {group-number} preempt
容许一台router要是有高的priority就可以马上霸占变成active router

4> standby {group-number} {hellotime} {holdtime}
group-number:默认设置为0,可配备范畴0-255
hellotime:默认设置为3,可配备范畴1-255
holdtime:默认设置为10,可配备范畴1-255

5> standby {group-number} track {type number} {interface-priority}
type number:使HSRP监管此插口,假如此插口down掉,则插口的HSRP priority值减掉interface-priority
interface-priority:插口down掉的处罚值。

6> show standby {type number} {group} {brief}
Switch#show standby Vlan11 11
Vlan11 - Group 11
Local state is Active, priority 110
Hellotime 3 holdtime 10
Next hello sent in 00:00:02.944
Hot standby IP address is 172.16.11.115 configured
Active router is local
Standby router is 172.16.11.114 expires in 00:00:08
Standby virtual mac address is 0000.0c07.ac01

7> debug standby [errors] [events] [packets]
监管HSRP全部的情况更改及hello包的推送。

8> debug standby terse
监管HSRP全部的errors,events和packets信息内容(不包括hello及advertisement packets)



Part Ⅷ: HSRP Configuration
RouterA:
!
interface Vlan10
ip address 172.16.10.32 255.255.255.0
no ip redirects
standby 1 priority 150
standby 1 ip 172.16.10.110
standby 2 priority 50
standby 2 ip 172.16.10.120
RouterB:
!
interface Vlan10
ip address 172.16.10.33 255.255.255.0
no ip redirects
standby 1 priority 50
standby 1 ip 172.16.10.110
standby 2 priority 150
standby 2 ip 172.16.10.120
RouterA#show standby brief
P indicates configured to preempt.
Interface Grp Prio P State Active Standby Virtual IP
Vl10 1 150 Active local 172.16.10.33 172.16.10.110
Vl10 2 50 Standby 172.16.10.33 local 172.16.10.120


Part Ⅸ: Tuning HSRP Operations
Subsecond Failover:
HSRP hellotime及holdtime能够配备为millisecond等级,从而将HSRP常见故障现场采样降低到一秒内。
switch(config-if)#standby 1 timers msec 200 msec 750

Preempt Time Aligned with Router Boot Time:
preempt是HSRP很重要的一个特点,它容许主router在历经failover后再度变成active router。
当主router重新启动后,HSRP应当等候此router与其他相接的机器设备创建好相对的通讯联接后再preempt HSRP。不然有可能会造成 packets不能达。
这时候就必须在preempt以前有一个延迟时间,以等候router进行它的通讯联接或路由器信息收集。这一延迟时间要依据不一样机器设备不一样的开机时间来设置,一般这一延迟时间应当比开机时间大一倍,以保证 主router有工作能力变成active router。
switch(config-if)#standby 1 preempt
switch(config-if)#standby 1 preempt delay minimum 180